3 заметки с тегом

composer

Как исправить ошибку Could not parse version constraint >=~2: Invalid version string «~2»

Вот так делаешь composer update (или install), а получаешь такую ошибку:

[UnexpectedValueException]
Could not parse version constraint >=~2: Invalid version string "~2"

Необходимо выполнить следующее:

php composer.phar global update

а после уже можно выполнить update или install:

php composer.phar update
2018   composer   php

Yii2 ошибка «The file or directory to be published does not exist: /path/to/project/vendor/bower/jquery/dist

Например, при первоначальном создании проекта, или при обновлении проекта с готовым composer.lock можно получить такую ошибку.
Решается следующим образом:

rm -rf ~/.composer/cache
rm -rf /path/to/project/vendor
composer global require "fxp/composer-asset-plugin:^1.2.0"
composer install

Здесь можно вспомнить как установить composer

UPD
Есть более актуальный способ решения проблемы:
В файле composer.json:

"config": {
    ...
    "fxp-asset": {
        "enabled": false
    }
},
"repositories": [
    {
        "type": "composer",
        "url": "https://asset-packagist.org"
    }
]

После выполнить:

composer install
2017   composer   composer install   yii2

Установка и настройка Composer

Без php не поставить, потому начинаем именно с php. Актуальная версия на сегодняшний день — это версия 7.0:

sudo apt install php7.0-cli

Теперь можно ставить Composer:

curl -sS https://getcomposer.org/installer | php

В итоге мы получим файл composer.phar, который и является исполняемым. Запускать его необходимо командой:

php composer.phar

Выполнив нехитрую команду, мы сможем исполнять вводя «composer» вместо «php composer.phar»

sudo mv composer.phar /usr/local/bin/composer

Если вы устанавлиаете Yii2, то обратите внимание, что необходимо установить плагин Composer Asset Plugin, т. к. позволит работать с некоторыми пакетами, которые контролируются менеджерами пакетов Bower и Npm. В частности, в Yii2 — это Bower, который «подтягивает» Jquery и Twitter Bootstrap.

composer global require "fxp/composer-asset-plugin"
2016   bower   composer   composer-asset-plugin   php   php-cli   yii2